デプロイログを見たら

目次

  1. 1. ログにこんなメッセージが
  2. 2. ということで更新します
    1. 2.1. 現在の状態
  3. 3. 再デプロイ
スポンサーリンク

Netlifyのbuild imageが古いと言われました\(^o^)/

ログにこんなメッセージが

とある日、NetlifyのDeploy logにこんな内容が出力されていました。

DEPRECATION NOTICE: Builds using the Trusty build image will fail after September 19, 2021

The build image for this site uses Ubuntu 14.04 Trusty Tahr, which is no longer supported.
All Netlify builds using the Trusty build image will begin failing in the week of September 19.

To avoid service disruption, please select a newer build image at the following link:
https://app.netlify.com/sites/********/settings/deploys#build-image-selection

For more details, visit the build image migration guide:
https://answers.netlify.com/t/end-of-support-for-trusty-build-image-everything-you-need-to-know/39004

このサイトは Ubuntu 14.04 を使っていて、2021/09/19 以降はビルドできんよ!ということらしいです。

ログに出力されていた下記リンクに詳しいことが書いてありました。

https://answers.netlify.com/t/end-of-support-for-trusty-build-image-everything-you-need-to-know/39004

ということで更新します

Ubuntu 14.04 にこだわる理由もない(というかサポートはとっくに終わっていた)のでログの内容に従って更新することにします。

現在の状態

Site Settings >> Build & Deploy >> Build image selection で確認できます。たしかに、現在は Ubuntu Trusty 14.04 になっていますね。

buildimage.png

デフォルトは Ubuntu Xenial 16.04 らしいのでとりあえずこちらに変えておくことにします。ベータ版の 20.04 を使うのもちょっと怖いですし。

再デプロイ

Clear cache and deploy site で再デプロイしましたところ無事警告が消えました。これデプロイログを見ていなかったら ある日いきなりビルドに失敗して「Why!?」っていたということか。あっぶな・・・

というわけで Netlify ユーザーの方はときどきログを見ておくことをおすすめします。

スポンサーリンク